Deliver Availability is Limited
Incident Report for Innovo
Resolved
Deliver is back online. Any manifests that may have been completed during the outage will remain in the live view until tomorrow. Any manifests that were in-progress during the outage and still in-progress will be adjusted real-time.
Posted Feb 01, 2017 - 14:15 MST
Investigating
We are currently experiencing issues displaying live data in Deliver. We will update the status once we have more information.
Posted Feb 01, 2017 - 12:50 MST