Phone Service Issue
Incident Report for Innovo
Resolved
Our phone system is back up!
Posted Oct 08, 2018 - 11:12 MDT
Investigating
Our phone service is currently down. We are working on resolving the issue. If you need to contact us, please send an email to support@goinnovo.com.
Posted Oct 07, 2018 - 16:50 MDT
This incident affected: Customer Support.