Route & Deliver Web Down

Incident Report for Innovo

Resolved

Closing
Posted Feb 04, 2025 - 14:54 MST

Monitoring

We will continue to monitor traffic today and make sure most systems are up and running. Currently the system is back up. We will be working off-hours tonight with our provider to make more permanent changes.
Posted Feb 04, 2025 - 09:30 MST

Identified

We have escalated the issue with our provider and they have responded with some recommendations we can put in place immediately. I will keep updating the status as we know more.
Posted Feb 04, 2025 - 09:03 MST

Update

The system is down again. We are investigating.
Posted Feb 04, 2025 - 08:28 MST

Monitoring

We have identified the issue and pushed traffic for now to our backup server. This is a DNS change so it might take a bit for everyone to come back online. You may have to close and re-open your browser to see activity again. Just a reminder, the Deliver app was fully functional during this outage.

Unfortunately this was the same issue as what happened last time. We will be making additional adjustments to fix.

We will continue to monitor throughout the day and provide additional updates as needed. Thank you so much for your patience. We know how critical these services are and will work to ensure this does not happen again.
Posted Feb 04, 2025 - 07:39 MST

Investigating

We are just receiving word that Route and Deliver Web are currently not functioning. We are investigating now and will provide status updates.
Posted Feb 04, 2025 - 07:00 MST
This incident affected: Deliver and Route.