Route & Deliver Experiencing Issues
Incident Report for Innovo
Resolved
Thank you all for your patience today! We will be deploying a fix tonight and pointing all traffic back to our primary server. As mentioned above, any manifest completed during the outage will not show breadcrumbs for the remainder of that route. Any manifest that was in progress and completed after the outage should show as completed with all breadcrumb data intact. The data impact only pertains to Deliver Web. All Eclipse processes were functioning as normal with signatures and photos successfully uploaded as stops were completed. If you have any questions about the data, please let us know. We are really sorry this happened and appreciate everyone's support!
Posted Mar 19, 2024 - 17:23 MDT
Update
We are continuing to monitor for any further issues.
Posted Mar 19, 2024 - 09:22 MDT
Update
We are continuing to monitor for any further issues.
Posted Mar 19, 2024 - 08:58 MDT
Monitoring
We are still working with AWS on the root cause however our fail over server is now online and seems to be holding strong so far. Deliver Web and Route are back online. There was some data loss while manifests were completed during the outage however if your manifest is still on the device and not yet been completed, all bread crumbs from those routes will eventually be sent to our platform. We'll send out another update when we have completely resolved the issue.
Posted Mar 19, 2024 - 08:54 MDT
Update
Just a quick update - we are currently working with AWS to address the issue. Looks like we went down at 9:25am Eastern Time today. Drivers should still be able to download manifests, capture signatures, and upload photos however it may be a little slower than normal. We will update you as soon as we know more!
Posted Mar 19, 2024 - 08:06 MDT
Investigating
We are currently investigation reports of Route and Deliver being down. We'll keep you updated as we learn more.
Posted Mar 19, 2024 - 07:31 MDT
This incident affected: Deliver and Route.