Limited Portal Availability
Incident Report for Innovo
Resolved
Intermittent portal issues appear to be resolved.
Posted Jan 08, 2018 - 12:02 MST
Monitoring
The Portal is back online. We will continue to monitor to make sure all issues are resolved.
Posted Jan 08, 2018 - 09:29 MST
Investigating
We are experiencing intermittent outages and are currently investigating the issue. All users currently logged into Innovo apps should not be experiencing the issue.
Posted Jan 08, 2018 - 09:28 MST