Portal Email Invites and Password Resets Issue
Incident Report for Innovo
Resolved
This incident has been resolved. All portal emails will come from no-reply@goinnovo.com. Thank you for your patience and support while we worked through it. If you have any questions, please let us know at support@goinnovo.com. Have a great night!
Posted Nov 18, 2020 - 16:29 MST
Monitoring
We believe the email issue has been resolved. All portal emails will now be coming from no-reply@goinnovo.com. We will continue to monitor this throughout the day but if you run into any issues, please reach out to support@goinnovo.com.

Thank you for your patience!
Posted Nov 18, 2020 - 10:58 MST
Identified
We continue to have issues with portal email invites and password resets and apologize for the inconvenience. We understand how frustrating this can be. We are no longer working with Microsoft on this issue and are now working with AWS to come up with a permanent solution.

If you need to invite anyone to an Innovo app, you can use the Set Password feature and let them know what their password is. Once the issue has been resolved, you can send them a password reset from the portal or they can use the Forgot Password on the login screen of the app to reset.

If you need to reset a users password that is already invited, we recommend you delete the user and re-invite them using the Set Password feature.

We will keep you posted throughout the day with status updates.
Posted Nov 18, 2020 - 09:49 MST
This incident affected: Customer Portal.