DNS Outage

Incident Report for Innovo

Resolved

Our service provider has restored DNS service. All of our services are now operational.
Posted Jun 07, 2019 - 09:57 MDT

Investigating

Our DNS provider is currently experiencing an outage which is effecting our services. We are currently investigating this issue.
Posted Jun 07, 2019 - 08:56 MDT
This incident affected: Deliver and Customer Portal.