Customer Portal Certificate Expired

Incident Report for Innovo

Resolved

Updated certificate is now in place. You should no longer see the security warning.
Posted Jan 17, 2017 - 11:28 MST

Identified

We are currently working on renewing the certificate. For now, your browser should allow you to pass through the warning into the portal.
Posted Jan 17, 2017 - 11:06 MST