Portal Email Invites and Password Resets Issue
Incident Report for Innovo
Resolved
The issue has been resolved. We had to change the email the portal uses so all invite emails and password resets will now come from noreply@goinnovo.com. if you see any issues moving forward, please contact support@goinnovo.com.
Posted Nov 16, 2020 - 15:13 MST
Investigating
We are currently experiencing an issue sending out invite emails and password resets. We are working with Microsoft on the issue and will post a status update as soon as we know more.

If you need to invite anyone to an Innovo app, you can use the Set Password feature and let them know what their password is. Once the issue has been resolved, you can send them a password reset from the portal or they can use the Forgot Password on the login screen of the app to reset.

Sorry for the inconvenience!
Posted Nov 16, 2020 - 14:42 MST
This incident affected: Customer Portal.