Google Maps Platform Issue
Incident Report for Innovo
Resolved
The issue seems to be mostly resolved. According to Google's status page (https://status.cloud.google.com/maps-platform/) they are still down however all of our apps seem to be working as normal. We'll continue to monitor and provide additional status updates as needed.
Posted Mar 18, 2022 - 15:13 MDT
Investigating
The Google Maps Platform is experiencing elevated error rates and increased latency for the Directions and Route APIs. This is affecting how our maps display in Deliver, Deliver Web, and Route and are in the process of investigating other potential issues. You can check the status of the Google Maps Platform here - https://status.cloud.google.com/maps-platform/.

We will send out another update when we know more.
Posted Mar 18, 2022 - 11:02 MDT
This incident affected: Deliver, Route, and Customer Portal.